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Using Mentor Graphics for Analog Simulation

 Introduction

This project is designed to give the first-timeMentor Graphics user an introduction to
the tools needed to perform schematic capture (design entry) and simulation of analog circuits.
Before working this project, you should have worked theDesign Manager andBold
Browser tutorial. If you have not, stop and work that tutorial now. By the end of this project, you
should be able to useDesign Architect to enter and verify schematics, and to useAccuSim to
simulate analog designs.

 Design Architect

To capture designs for simulation,Design Architect is used.Design Architect is a
drawing program that knows about electrical components, wires, busses and electrical rules. You
can useDesign Architect to draw schematics for simulation, or just to get a neatly formatted
schematic printout.

Start upDesign Manager by clicking onDesign Tools ⇒Mentor Graphics ,
just like in the tutorial. OnceDesign Manager has loaded, maximize its window. Use the pop-
up menu (right mouse button) command to update the Tools window. The icon forDesign
Architect is labeleddesign_arch . Double click on theDesign Architect icon; you should
see a message in the lower left letting you knowDesign Architect is starting up. You can mini-
mizeDesign Manager now. Remember, it may take some time, but you will soon see a
Design Architect window.

Once loaded, (after the window maximizes itself), you will see a palette of icons on the
right side of the window. Most every Mentor tool has a palette of this type. You can press these
icons (with one mouse click) instead of going through the menus to perform certain functions.
These icons will change depending on what you are doing, as you will see.

The design that you will enter is a simple RC circuit, shown in Figure 1. Use the following
steps to enter the circuit:
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FIGURE 1. RC circuit

1. Click on theOPEN SHEETpalette icon or selectFile ⇒Open⇒Sheet from the menu bar.
Mentor refers to schematics as “sheets” because the schematic for one circuit could span mul-
tiple “sheets” of paper. Mentor also refers to circuits as “components” because any circuit
could be used as a single component in a higher-level design.

2. A form will appear. Note the path in theComponent Name  box. This is the path toyour
mgcdirectory; you should write this down for later use. Click in theComponent Name box
and append/RC to the path in the box. This will create a component (circuit) called “RC”.
When you have typed this in,OK the form.

3. An empty sheet will appear in theDesign Architect window. This sheet is where you will
put the parts for your circuit and wire them together. To begin, you need to select a library of
components to use. Do this by selectingLibraries ⇒MGC Analog Libraries  from
the menu bar.

4. Note how the palette changes to show a list of analog parts libraries. You will be using the
Generic Parts  library for your circuit. Open this library by clicking onGeneric
Parts  in the palette area.

5. Again, the palette changes, displaying the various parts you can choose from. First, add a
resistor. Select a horizontal resistor (RESIST-H ) by clicking on its icon.
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6. Now, move your mouse pointer onto the schematic sheet. A ghost image of the resistor will
appear; you can move it to the position you want to place it. To place the resistor, simply click
once. If you accidentally select a part you don’t want, click onCancel  in the gray prompt
box (at the lower left of the window), or use theEsc  key to cancel the command.

7. To place the other horizontal resistor, you can click in theActive Symbol window (in the
far upper right corner - it shows a picture of the resistor) to get another copy of the part, which
can then be placed. You could also copy the part you already placed on the sheet, or click on
RESIST-H  in the palette again.

8. Next, place the capacitor in the same way: click on theCAP icon, move the ghost image to
where you want it, and click to place it on the schematic. Be sure to leave space between all of
the components, especially their terminals. Do not overlap any components, or you will not be
able to simulate your design later.

9. You may soon find that your sheet is rather crowded. If you need to, you can zoom out to get
more area to work with. ChooseView ⇒Zoom Out  from the menu bar to do this. Using
View ⇒All  will zoom the view properly to display everything on your sheet.

10. Place the ground connection (GROUND) and vertical resistor (RESIST) using the same pro-
cess you used for the other parts.

11. Place the input port, labeled IN in Figure 1, by selecting thePORTINicon. This is where you
will input signals to the circuit. Also, place the output port, OUT, the same way. It is called
PRTOUT. They will automatically be labeled NET; this label will be changed later.

12. Next, add wires to connect the components. If you like to use function keys, you can start the
wiring tool by pressingF3. Notice the function key definitions at the bottom of the window.
You could also clickADD WIRE from theADD/ROUTE palette. To show the palette icons
while the libraries palette is visible, use the pop-up menu (right mouse button) while the
mouse is over the palette, then selectDisplay Schematic Palette .

13. Wire the circuit as shown in Figure 1. To start a wire, click once. To place a bend in the wire,
click once again. To end a wire, double click. For a wire to be electrically connected to a com-
ponent, it must start or end on the purple diamond on the terminal of the component. You can
also start or end a wire on any part of an existing wire (e.g. between the horizontal resistors).
To undo your last click, you can use theBackspace key. When you have finished wiring the
circuit, click onCancel in the prompt at the lower left, or use theEsc key, to quit the wiring
tool.

14. Notice how Figure 1 has different values for the capacitance, resistances and the input and
output port names. All of these names/values are referred to as “text properties” in Mentor.
Let’s change the values of those properties now. First, unselect everything by choosing
Edit ⇒Unselect ⇒All  from the menu bar. You could also use theF2 key.

15. Next, if you haven’t already done so, get the schematic palette icons back. use the pop-up
menu in the palette to selectDisplay Schematic Palette .

16. Go to theTEXTpalette by clicking on its button in the second row of the palette. These brown
buttons are the palette selectors. Clicking on each one brings up the corresponding palette.
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17. To change the properties, you will first need to select them. There are several ways to do this;
we’ll use the simplest. Place the mouse over the text you want to select and, while holding
down theshift  key, click. While the shift key is held down you can only select text
properties, and they can only be selected as long as you hold down the shift key. Use this
method to select the properties you wish to modify. In this case, you should select bothNET
properties on the ports, the10P on the capacitor and all the10K’s on the resistors.

18. As you click on them, notice how they turn white, denoting they are selected. If anything else
is selected, you should unselect it by clicking on it, or unselecting all and selecting only the
properties mentioned above. Unlike other windowed applications, once something is selected
in Mentor, it stays selected. Once they’re all selected,Sel: 6+  should be displayed in the
upper-left corner. If the number is different, too few or too many items are selected.

19. Now, clickCHANGE VALUEin theTEXTpalette. A prompt box will appear at the bottom of
the screen. Notice how the property value it is displaying is also the only highlighted (white)
object in the circuit. This is so you know which property you are changing. Simply type the
correct new value in theNew Value box. In the case of the leftNET, you should change it to
IN . In the case of the rightNET, you should change it toOUT. Press the return key after you
have typed in the new name and the value changes. When the last value is changed, the prompt
disappears. The new resistor values are 50, 5k and 5k, as in Figure 1. The new capacitor value
will be 100u.

20. Now, add your name to the circuit. In theTEXT palette, click on theADD COMMENT button.
Just type your name in the prompt in the lower left corner and press return. Then, move the
cursor onto the sheet and click where you want to place your name. If you unselect your name,
you will see your name is in green text. This means the property is a comment (i.e. it has no
electrical meaning).

21. Finally, you must check and save your work. You must check your sheet before you save it to
be sure you have not made any basic mistakes. If your sheet does not pass the check, the sim-
ulator will not simulate the circuit. To check your work, chooseCheck ⇒Sheet  from the
menu bar. A report will appear. If you have any errors or warnings, you will need to fix them
and check your sheet again. If you have an error or warning, the report will tell you it is at
something like N$483 or I$372. This is the handle tag Mentor uses to keep track of things. To
figure out what it refers to, highlight the handle in the report, then look at your schematic. The
corresponding part will be highlighted in your circuit as well (this is calledcross-selection).
Fix any problems you may have and check your circuit again.

22. When your circuit checks with no errors or warnings, close the report window. Save your
design by choosingFile ⇒Save Sheet  from the menu bar.

23. Don’t forget to get a printout of your new circuit. You will first need to setup which printer
you will use by choosingMGC⇒Setup ⇒Printer...  In the form that appears, click on
the desired printer name, click theSelect Printer  button andOK the form. Then, from
the menu bar, chooseFile ⇒Print Sheet: , set any options desired (the defaults should
be suitable),OK the prompt bar and go collect your printout.

At this point, you are done withDesign Architect. Exit it by closing its main window.
You have now completed the schematic capture of the RC circuit. In the next section, you will do
a transient analysis of the circuit usingAccuSim, the analog simulator.
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 AccuSim

You are now ready to simulate your design. Your circuit should appear in the Navigator
window ofDesign Manager. If it does not, select the Navigator window and use the pop-up
menu commandUpdate Window . Now your design, RC, will appear. To invokeAccuSim on
your design, click on the RC icon to select it. Then use the pop-up menu in the Navigator to select
Open⇒AccuSim . After a short time, a new window will appear.

OnceAccuSim has loaded, it will maximize its window, and you will see your schematic
in a smaller window inside theAccuSim window. The white window in the upper left will let
you watch the status of your simulation. The following steps will guide you through a transient
analysis of your circuit.

1. First, you need to specify an input signal. Mentor calls this a “force.” You need to specify
which signal is to be forced, by selecting the signal. Simply click theIN  port in your sche-
matic. You should see the wire turn white, denoting that the input is selected.NOTE:  The
default size for the schematic is sometimes too small to be readable. If this is the case, you can
enlarge the window and/or make the schematic fill the window. To make the schematic fill the
window, typeShift-F8  with your mouse pointer in the schematic window. (You can see
from the function key definitions at the bottom of the window that this is the “view all” key).
Optionally, you can selectView ⇒All  from the pop-up menu or the menu bar. All of these
actions result in the schematic filling the window.

2. With the input selected, click theADD FORCE button on the palette. In the form that appears,
note how the selected signal, IN, is the signal name in the form. We’ll use a sine wave for the
input. It will be specified in the time domain, so click on theTime  button then click theSIN
button. Now, the magnitude and frequency of the sine wave must be defined. Enter5V for the
magnitude,2Hz for the frequency andOK the form.

3. Now you need to tell Mentor what type of analysis you wish to perform. To do this, click
SETUP ANALYSIS from the palette. A form comes up and you want to do aTransient
analysis, so click that button now.

4. The form changes, and now you can enter the information needed for a transient analysis (as in
SPICE). You’ll use a three second analysis with ten millisecond steps, so enter a time step of
10ms and a stop time of3s . Also, be sure to turn theUse Initial Conditions box on,
by clicking on it, to be sure the capacitor is properly initialized.OK the form.

5. You can now run the simulation. Simply click the blueRUNbutton on the palette. SelectOKon
the Keeps form that appears. This tells the simulator what signals to keep track of. In this case,
the simulator will keep track of everything in the schematic.

6. You can watch the Status box to see the simulation run. When the simulation is done, you have
several options for gathering and examining output results. One option is to plot the results
graphically. To do this, select the signal(s) in the schematic window that you wish to plot. In
this case, we’ll use both the input and the capacitor voltage. Click on the IN port to select the
signal. Since the capacitor is connected to ground, you can look at that node voltage above the
capacitor to see the capacitor voltage. Click on the wire connected to the top of the capacitor to
select it. You should now have both signals (IN and the capacitor) selected. If you accidentally
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choose a terminal and not a wire, you will see the current and not the voltage. (A terminal is
highlighted with a small white cross at the terminal.)NOTE: In AccuSim, when you want to
view a voltage, you select the wire. When you want to view the current into a component’s ter-
minal, you select that terminal.

7. If you selected an object you didn’t want to select, simply unselect it by clicking on it again.
Once the desired signals are selected, clickTRACE on the palette. Both signals will now be
plotted.

8. To add signals to the Trace window, simply select them and clickTRACE. Let’s add the current
into the capacitor now. First, unselect everything, then select aterminal on the capacitor by
clicking on the topmost point of the capacitor. You should see a white cross, but the wire
should not be highlighted.

9. Click theTRACE button again and the trace is added to the window. You do not have to rerun
the simulation to get a window update. This is because you chose to have all signals kept in the
Keeps form.

Sometimes, it may be difficult to determine what a signal in the plot corresponds to in the
schematic. It is obvious that one of the signals plotted is the input since it has the label “IN”. But
what about the current? Here, the names are system assigned handles and not obvious to us what
they correspond to. Using cross-selection, as you did inDesign Architect, is an easy way to see
what the correspondence is. Make the Trace window active and follow these steps:

1. Unselect everything, so no signals are selected in the legend of the Trace window.

2. Now, select the current signal that has the handle that looks something like/I$2/POS:i . Be
sure to select the text on the line that shows the trace color in the legend. If you select the line
above it, you will not see the proper results.

3. When you select the line in the legend, the corresponding signal is selected in your schematic
too. Now you can see the correspondence between the trace and the circuit signal.

4. Cross-selection works the other way too. If you select the IN signal in the schematic window,
its plot will be selected in the Trace window as well.

Another way of gathering output data is to examine theOutfile . TheVIEW OUTFILE

icon is located on theRESULT palette. TheOutfile  is much like the output file created by a
SPICE simulator. You can print the data from both theOutfile  and the Trace window. How-
ever, the Trace window is usually more informative and compact.

To print the Trace window, setup the printer just as you did inDesign Architect.
(MGC⇒Setup ⇒Printer...)  Then with the Trace window active, choose
File ⇒Print ⇒Active Window... from the menu bar.OKthe prompt bar and go get your
printout. To print theOutfile , you could just print the entire file using the method above with
theOutfile window active. However, the file is often as long as ten pages, and most of the data
may not be needed (remember your print quota of 500 sheets per quarter?) A better approach is to
highlight only the information you want to print. Then chooseFile ⇒Print ⇒Document...
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from the menu bar. In the prompt, change theportionbox toselected . and clickOK. This will
cause Mentor to only print the portion you have selected in theOutfile .

Now you have gathered the data you need from the simulation. But what if you made a
mistake, and the capacitance should really be 50 UF? Do you have to go back toDesign Archi-
tect? The answer is no. Let’s see how you can continue your simulation and yet change the com-
ponent value.

1. First, close any report windows you may have open (like theOutfile ). You can leave the
Trace window open if you like.

2. To change the capacitance from 100 UF to 50 UF, select the capacitor (not its value) in the
schematic window.

3. Next, selectEdit ⇒Property ⇒Change  from the pop-up menu in the schematic window
or from the menu bar.

4. In the form, one property is namedinstpar  - it’s the value of the capacitance. Select this
property line and clickOK.

5. Another form appears, and you can type in the new value. Do not change any other items. Press
return or clickOK when you are done.

6. Notice how the value turned red on the schematic. This means that you have edited the original
schematic. If you wish, you could propagate that change back into your original schematic
later. (Mentor calls this a “back annotation.”) For now, though, you have only changed the
value thatAccuSim sees.

7. Everything is now ready, so clickRUN to rerun the simulation.

8. The new results you see in the Trace window will be from the circuit with a 50UF capacitor.

You can continue this process as many times as you need to. Be sure to get a printout of
this new data for your report. To help determine what circuit this data came from, you may want
to put a label on the Trace before printing it. With your mouse in the Trace window, choose
Chart ⇒Add Text: from the pop-up menu. In the prompt box, enter the text or label you want
and click OK. Now move the cursor back to the Trace window, where you will get a set of cross
hairs. Place the cross hairs where you want the origin (lower-left corner) of your label to be and
click to place it. When you have printed out the data you need, you will be done withAccuSim.
Exit the program by closing its main window. You will get a form, and you could clickOKto save
your simulation results and setup. If you have made printouts, though, you probably will not need
to save your results, so selectWithout Saving  andOK the form.

You can now exitDesign Manager by closing its window. You now know how to enter
a design into the system and simulate it using the analog simulator. In the next project, we’ll per-
form other types of analysis on a simple transistor circuit.
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 Report

The report should be typed and follow the report format discussed or handed out in class.
Be sure to include:

• The printout of your circuit fromDesign Architect.

• The Trace printouts from the 100 UF capacitor and 50 UF capacitor simulations.

• Any portions of the Outfile you feel are needed for your report (probably none).


